Overview
When installing or un-installing Microsoft Windows component technologies on Windows Vista/Seven/Win2K8-Server (or newer) you may encounter a message box similar to:
Error 1402. Could not open key: UNKNOWN\Components\C9AE13788D0B61F80AF18C3B9B1A1EE8\75997DDB1085D2A40BE958E2F76AD410. Verify that you have sufficient access to that key, or contact your support personnel.
Environment
- Windows Vista
- Windows 7
- Windows 2008 / R2
- Windows SBS 2008 / 2011
Root Cause
The error is generally caused by insufficient or incorrect permissions on the named registry keys or parent container of such registry keys.
Resolution
NOTE: It is recommended that you back-up your computer or at least the registry before taking these actions.
IMPORTANT: You must be logged in as the 'administrator' (or an account with full administrator access) and have UAC disabled (User Access Control).
- From the START menu, execute "Run.." and then type "regedit"
- Navigate to the following parent container:
-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components
NOTE: The 'S-1-5-18' key may be different on your computer.
-
- As in the screen snapshot above, we wish to look for the first of the two GUIDs, namely
"C9AE13788D0B61F80AF18C3B9B1A1EE8"
. Scroll through the children of the "Components" key to locate this corresponding first of two GUIDs from the message box shown above. Most often this will have a "+" beside the folder since it'll have one or more children items in it (one of which will be the second GUID from the message box shown above). You can also use the "Find" command within the registry editor but that is a much slower and more tedious operation to do.
- Right click on the parent container registry key, which is the
"C9AE13788D0B61F80AF18C3B9B1A1EE8"
for this example. Our screen snapshot below uses the"000085D..."
registry key for illustrative purposes only. Choose "Permissions..."
- On the "Permissions for..." dialog box which appears next, press the "Add.." button and add in the "Administrator", "Administrators" and "SYSTEM" accounts. For ourselves, we also made sure to add in our own local account which had administrator privileges.
- Back on the first "Permissions for..." dialog box, click on each account in the top-list and make sure each has the "Full Control = Allow" and "Read = Allow" permissions.
- Click the "Advanced" button so that the "Advanced Security Settings" window appears.
- Click the "Permissions tab" enable the check mark the box named "Replace all child object permissions with inheritable permissions from this object", then press the "Apply" button.
- On the "Owner" tab, highlight the "Administrators" name in the lower list box, enable the checkmark box called "Replace owner on sub containers and objects" and press the "Apply Button".
- Repeat the previous 2 steps once more. This time around you shouldn't get any errors about not being able to update the permissions on the child keys.
- Exit these dialog boxes by pressing the "OK" button, so that you are back to the main registry editor.
- Go and re-run your Microsoft installer or un-installer. It is recommended that you right-click on its icon and execute "Run as administrator..." if available.
- If you continue to get this "Could not open key" message, on the exact same keys, then you didn't do the above operations correctly.